15th February 2019

Scheduled Maintenance, scheduled 7 months ago

UPDATE

This maintenance was completed and all was up and running again by 5pm Eastern, Saturday night. Thank you for your patience!

In our continued efforts to provide the best possible user experience, we will perform scheduled system maintenance on the Big Biller legacy servers this weekend.

This maintenance will begin at on Saturday morning, February 16 2019, and end on Sunday evening, February 17, 2019.

Please note that this scheduled maintenance will cause "down time" for the Big Biller software. This means you will not be able to access your database during this time, and if you have a Job Board connected to your Big Biller account, you will not be able to access the Job Board, as well.

We will send an email once the system maintenance is complete and all of the Top Echelon software, tools, and services are once again fully accessible.

UPDATE

This maintenance was completed and all was up and running again by 5pm Eastern, Saturday night. Thank you for your patience!