Rate limit exceeded errors

Incident Report for Top Echelon Recruiting Software

Resolved

The Rate Limiting issue have now been stable for 5 days. This issue has been resolved.
Posted May 29, 2025 - 11:17 EDT

Monitoring

Earlier today, users of TE Recruit may have experienced intermittent service delays. After a thorough investigation, we identified the root cause as a bug introduced during a recent infrastructure update. Over time, this issue led to an unexpected rate-limiting condition that impacted performance.

Upon discovery, we promptly reverted the update, which resolved the issue and restored normal service. We are continuing to monitor the system closely to ensure stability.

We sincerely apologize for any inconvenience this may have caused and are implementing additional safeguards to prevent similar issues in the future.

Thank you for your patience and understanding.
Posted May 23, 2025 - 12:52 EDT

Investigating

Some users have reported experiencing "Rate limited exceeded" errors. We are looking into the issue.
Posted May 23, 2025 - 09:52 EDT
This incident affected: Recruiting Software and Top Echelon Network.