Service Disruption

Incident Report for Top Echelon Recruiting Software

Resolved

The earlier service disruption has been resolved, and all services are operating normally.

We have continued to monitor the system and have not observed any further issues.

Thank you for your patience and understanding.
Posted Sep 10, 2026 - 17:55 EDT

Monitoring

We experienced a brief service disruption that may have impacted access to the system.

The issue has been addressed and services appear to be operating normally. Our development team is continuing to monitor things closely to ensure everything remains stable.

We appreciate your patience and apologize for any inconvenience this may have caused.
Posted Sep 10, 2026 - 17:27 EDT
This incident affected: Recruiting Software and Top Echelon Network.