Outgoing Email Delay
Incident Report for Top Echelon Recruiting Software
Resolved
The email queue has caught up. All should be resolved now.

We apologize for any inconvenience this caused.
Posted Jul 24, 2024 - 08:45 EDT
Monitoring
A fix has been implemented and emails are starting to go out now.

Careers Pages should be back up now as well.

We are continuing to monitor the emails. The system it working through the queue now.
There will still be a delay with any new mass emails sent out as it works on getting through the queue.
Posted Jul 23, 2024 - 14:41 EDT
Update
We are continuing to work on a fix for the email queue.

A separate error is occurring on the Careers Page. We are investigating this issue further and working to resolve it as soon as possible.

We appreciate your continued patience.
Posted Jul 22, 2024 - 15:40 EDT
Identified
There is currently a delay for all outbound emails sent through Top Echelon.
We are working on a solution and the queued emails will be delivered as soon as possible.
Posted Jul 22, 2024 - 13:40 EDT
This incident affected: Recruiting Software and Careers Pages.