Random Logouts and Loading Issues

Incident Report for Top Echelon Recruiting Software

Resolved

This issue has been resolved.
Posted Jul 09, 2026 - 19:50 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 09, 2026 - 19:16 EDT

Identified

The issue has been identified. We're working to correct the problem.
Posted Jul 09, 2026 - 19:08 EDT

Investigating

We are aware of a some users being logged out and unable to log back in We're investigating.
Posted Jul 09, 2026 - 19:01 EDT
This incident affected: Recruiting Software.