Performance Issues Due to AWS Outage

Incident Report for Top Echelon Recruiting Software

Monitoring

Systems are showing signs of recovery. We’re continuing to closely monitor performance to ensure full stability.
Posted Oct 20, 2025 - 15:27 EDT

Identified

Amazon Web Services (AWS) experienced a major outage on the morning of October 20, 2025, which has since been mitigated. The disruption primarily stemmed from a DNS issue impacting the US-EAST-1 region in Northern Virginia, which affected services globally.
While most AWS services have now recovered, some platforms may still be clearing a backlog of requests, and some users might experience minor issues.

Ongoing effects: While normal operations have largely resumed, AWS noted that some requests may be "throttled while we work toward full resolution".

This throttling seems to be causing issues with outbound emails sent through Top Echelon, along with some intermittent performance issues.
We are continuing to monitor and do what we can as Amazon works to address these issues.
Posted Oct 20, 2025 - 10:27 EDT
This incident affects: Recruiting Software, Careers Pages, and Top Echelon Network.