System Outage

Incident Report for Top Echelon Recruiting Software

Resolved

This incident has been resolved.
Posted Jul 09, 2026 - 17:07 EDT

Monitoring

The system outage appears to be resolved.

Our team has implemented corrective measures and is continuing to closely monitor system performance to ensure service remains stable. We will provide additional updates if necessary.

Thank you for your patience while we worked through this issue.
Posted Jul 09, 2026 - 16:51 EDT

Investigating

We apologize for the interruption in your use of our products.
We are currently experiencing some issues on our end.
We apologize for the inconvenience and are working to get it corrected as soon as possible.
Posted Jul 09, 2026 - 16:44 EDT
This incident affected: Recruiting Software and Top Echelon Network.