Issues with Some Top Echelon Software Features
Incident Report for Top Echelon Recruiting Software
Resolved
Mass email functionality has been restored and all other issues should be resolved at this time.
We appreciate your patience.
Posted Jul 20, 2022 - 12:39 EDT
Update
Outgoing standard email functionality has been restored. This includes the receiving of system email notifications.

We are still working to fully resolve issues related to sending mass emails, but will have that corrected as soon as possible.
Posted Jul 20, 2022 - 12:16 EDT
Update
The issues with the Careers Page have been resolved at this time. Additionally, all issues with editing Jobs, parsing People records, using the Browser Extension, and importing spreadsheets via the Contact Importer should have been resolved as of yesterday afternoon.

We are still working to fully resolve issues related to sending email, but will have that corrected as soon as possible.
Posted Jul 20, 2022 - 09:47 EDT
Identified
The issues with adding/parsing People records, using the Browser Extension, and importing spreadsheets via the Contact Importer have been resolved at this time.

We are still experiencing issues with sending emails, making edits to Jobs, and the new Careers Page module. We are continuing to work to resolve these as soon as possible.
Posted Jul 19, 2022 - 15:27 EDT
Investigating
We are currently experiencing issues with sending emails from Top Echelon Software, adding records via the Browser Extension, importing spreadsheets via the Contact Importer, and making edits to some Jobs. We are actively investigating the situation and working to resolve the problems as soon as possible.
Posted Jul 19, 2022 - 14:46 EDT
This incident affected: Recruiting Software.