All background processes have now fully recovered, and all queues are caught up. Reports, contact imports, and email sending are now operating normally.
We’ll continue to monitor system performance, but no further impact is expected.
Thank you for your patience and understanding throughout this incident.
Posted Nov 03, 2025 - 17:04 EST
Monitoring
Our systems are now recovering, and most background processes are returning to normal operation.
You may still notice some delays in reports, contact imports, and email sending as the system works through backlogged queues. We’ll continue to closely monitor performance to ensure everything stabilizes fully.
Thank you for your patience while we worked to resolve this issue.
Posted Nov 03, 2025 - 15:55 EST
Identified
We are currently experiencing an issue affecting background processes within the system. This is causing delays in reports, contact imports, outgoing emails, and other related services, to name a few.
Our team is actively investigating the cause and working to resolve the issue as quickly as possible.