Degraded Performance
Incident Report for Top Echelon Recruiting Software
Resolved
This incident has been resolved.

We apologize for any inconvenience this may have caused and we appreciate your patience.
Posted Feb 28, 2024 - 20:02 EST
Monitoring
A fix has been implemented and we are currently monitoring the results.
Posted Feb 28, 2024 - 17:56 EST
Update
We have deployed changes that have helped address some performance issues we were seeing within the system. However, these changes do not appear to have addressed the root of the issue for many customers.

We have identified an update that was made previously that we believe could be contributing to these issues.
We are working on a fix to roll that update back soon.

Once that change has been deployed, we will monitor the system for any further issues.
Posted Feb 28, 2024 - 16:10 EST
Identified
We are aware of intermittent timeout, slowness, and other performance issues within the software.
Our developers have a fix prepared and will continue to monitor the system for further issues after deploying it within the day.
We apologize for any inconvenience these issues may be causing, and we appreciate your patience and continued business.
Posted Feb 28, 2024 - 11:56 EST
This incident affected: Recruiting Software and Top Echelon Network.